The Chrysler Minivan Fan Club Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-6 of 6 Results
  1. 5th Generation Chrysler Minivans: 2008-2020
    In my attempts to have rear heat working in my 2010 T&C 4.0 I have tried the following… -replaced water pump and timing belt -flushed the whole system with hose and confirmed fluid is flowing to rear heater core, -replaced front and rear heater cores, -replaced both rear blend door actuator...
  2. 4th Generation Chrysler Minivans: 2001-2007
    Hey there, I think I have a bad thermostat on my '07 Dodge Grand Caravan SE. Temp gauge is fine, blower is fine, but no heat front or back. When I switch it to recirculate, I hear a thump or a clunk in front of the passenger floor/glove box area. Brief heat, then nada. Fluid level light came on...
  3. 4th Generation Chrysler Minivans: 2001-2007
    Hi, I'm not getying any heat on my 03 T&C 3.8L. Hopefully someone can point me in the right direction. The A/C works perfectly fine. When I switch to heat, the air starts off luke warm for a few second then it blows outside temperature air. The other thing that happens when i switch to heat...
  4. 5th Generation Chrysler Minivans: 2008-2020
    Hey Peeps. I have a 2010 Town and country Touring with the 4.0L engine. I can only get heat at high RPMs. I have replaced the heater core. Bled the system as best as I could with the front end off the ground. I have good heat until I pull out of garage then the passenger side temp goes cold...
  5. 4th Generation Chrysler Minivans: 2001-2007
    So went to use the heater for the first time and after 15 minutes of "warming up" only the mere hint of heat. After 30 minutes it was warm on the high setting. It has Automatic Temp Control and the issue applies to the whole van ... Driver, Passenger and Rear heat. It also occurs at all temps...
  6. 4th Generation Chrysler Minivans: 2001-2007
    I'm going to search threads but thought I'd ask my specific question. 2005 T&C 1) Front fan works well; nothing coming from rear fans (front and rear controls are set properly). 2) Checked coolant. It was very low...as in below the MIN level. Added coolant to just below MAX level. 3) After...
1-6 of 6 Results
Top