The Chrysler Minivan Fan Club Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2008 Town and Country 3.8L with 211,000. Just returned from a trip to Nevada, about 4000 miles round trip. No issues at all. A day later, I went to get gas, check engine light came on and the engine began idling very rough. I went to AutoZone to scan it and it said I needed fuel injectors. A friend replaced the fuel injectors, spark plugs and wires. Ran great for a day and on the second day I went out to start it and my battery was dead. Once I got it jump-started again, check engine light was on. Took it to have another scan and now it says O2 sensors and that my car was running lean. Now back to the battery draining. It's a new battery. I noticed that evening when I turned off the key, my dash lights stayed on and wouldn't turn off. I imagine this is what is draining my battery. I have no idea why those dash lights are staying on. Sometimes it's the park reverse neutral light with the mileage light but most of the time it's the mileage light that stays on. I know my way around a little bit but I'm not a mechanic by any means. What might take a man 4 to 5 hours to fix might take me three days but my mission is generally accomplished. Kindly advise me if you can. Thank you
 

·
Registered
Joined
·
15 Posts
I have owned an 08 since new and the check engine light has been on about half the time. The mechanics that I taked with don't think it is a big deal. It runs fine. Right now the fuel cap light is on and I replaced the cap twice. Also, Autozone's scanner has been wrong for me a few times. I would take it to a mechanic that you trust. They have better scanners.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I took it to a mechanic today. He got the same code. Running lean. Said probably catalytic converter. Didn't want to mess with why the dash lights stay on and run battery down. Sigh. Thank you for your reply though.
 
1 - 3 of 3 Posts
Top