The Chrysler Minivan Fan Club Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
this garage is killing me in labor 3 weeks still not fixed also the ecm was tested 3 crank 1 cam sensor still no spark
 

·
3rd gen > all others
Joined
·
2,612 Posts
Did they check for an open in the wiring? Are they installing the sensors correctly (with a paper spacer)? Can they verify they are getting a cam and crank sensor signal while cranking the engine? Sounds like the "garage" is using the "poke and hope" method of firing the parts cannon at it and not properly diagnosing the real problem. Could be as simple as a failed coil pack/wiring. A broken flex plate will also cause the same thing.
 

·
Registered
Joined
·
6 Posts
Please note: These may not throw a code (My experience)
.You didn't specify Engine size, so:
The shop should have a scanner that would show the pulses from the Crank and Cam sensors. These send their signals to the ECM (Engine Computer) -- 2.4L it is under the left inner fender. 3.3L/3.8L Under hood bolted to the inside of the left fender.
Check the voltage on the Coil Pack plug. You didn't specify Engine size, so:
Test with ignition ON
If 2.4L Engine -- center pin (Pin 2) for +12V thru the ASD (Auto Shut Down Relay)
If 3.3L/3.8L Engine -- Pin 3 (Dark Green/Orange wire) for +12V thru the ASD (Auto Shut Down Relay)
Auto Shut Down Relay -- In the Power Distribution Center (Under the Hood) Fuse 17 (20A) supplies power to pin 30 (Diagram on relay). If there, change relay with another like it in the panel.It gets energized by ignition ON.
Please note: It takes 15 Min MAX to change the Cam Sensor!
Possible Codes:
Cam Sensor -- P0340 thru P0344 (Usually I see P0340)
Crank Sensor:-- P0335 thru P0339 and/or P0385 thru P0389)
Also Possible codes for Crankshaft/Camshaft Sensors P1391 thru 1398 (Usually I see P1391)
 
1 - 3 of 3 Posts
Top