The Chrysler Minivan Fan Club Forums banner
1 - 15 of 15 Posts

· Registered
2011 T&C Limited, 120K miles
Joined
·
67 Posts
Discussion Starter · #1 ·
I would appreciate some suggestions to fix the issues I have with 2011 T&C RHR uconnect. When I press VR button on the unit or the steering wheel, I don't hear anything and the screen just shows below. When I press phone button, it doesn't do anything either.

Also, I can connect my Galaxy S21 via bluetooth. I can receive calls and call using the number pads on the screen. However, I can't stream music from my phone.

I have tried to pull the M12 and M10 fuse following some suggestions on this board but it didn't solve my issues.

Computer Output device Personal computer Electronic instrument Font
 

· Registered
2009 Dodge Grand Caravan SE
Joined
·
338 Posts
Have you tried a master reset of your RHR radio?

 

· Registered
2019 Dodge Caravan 35th Anniversary Edition
Joined
·
111 Posts
How about going into the phone "paired device" settings, and looking at the Bluetooth connection permissions and allowing "audio". On my phone with Uconnect, I have sliders to turn on "Calls", "Audio", "Contact Access" and "Message Access". That's on my Samsung A8 phone and my 2019 DGC.

Hope this helps!
 

· Registered
2011 T&C Limited, 120K miles
Joined
·
67 Posts
Discussion Starter · #8 ·
How about going into the phone "paired device" settings, and looking at the Bluetooth connection permissions and allowing "audio". On my phone with Uconnect, I have sliders to turn on "Calls", "Audio", "Contact Access" and "Message Access". That's on my Samsung A8 phone and my 2019 DGC.

Hope this helps!
Thanks for the suggestion. I did slide the permissions for audio.

It just doesn't stream music. As you can see, it says failed to play. Also, the little icon at the bottom with phone and address book has an arrow that keeps pointing from the phone to the address book.

I will try an older phone and see if it works.

Flat panel display Gadget Font Display device Mobile device
 

· Registered
Joined
·
3 Posts
I have the same problem, tried all the same suggestions, no luck. Did you find a solution? It just doesn't stream music -- phone is connected, I can make /receive calls, screen shows battery and signal bars. Green check by music on list of paired devices. Phone shows connected and Spotify playing music in car mode with bluetooth icon. No sound from car audio, "Failed to Play". I' tried connecting USB, but phone does not show up on device screen plugged into console or radio USB port.
 

· Registered
2011 T&C Limited, 120K miles
Joined
·
67 Posts
Discussion Starter · #13 ·
No. I didn't find a solution to fix it. I ended up replacing the unit. You can read the post in the link with some replacement info. Good luck!

 

· Registered
Joined
·
2,842 Posts
Did you try getting new software/firmware? Search for uconnect firmware update and look for an official looking site.
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top