The Chrysler Minivan Fan Club Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter #1
Hi folks..
Battery warning indicator yesterday, then MIL and other lights coming on (ABS, traction control, emergency brake!), engine in limp mode, AC blwoing full heat, etc, today. Checked the battery voltage: 11.8 volts at power off, dropping to 11.0 at start position and down to 8 volts when started and then engine stall shortly afterwards.

Anyone else experienced this? Seems like some sort of failure in the charging system. Will be taking it to the dealer in the morning (if it will drive once I've recharged the battery). Is battery itself covered by the 3/36 warranty?
 

·
Registered
Joined
·
47 Posts
Discussion Starter #3
Hmm.. well, I dunno.

I disconnected the battery and put it on a charger (computer controlled). It fully recharged battery in 6 hours or so with it reading just 12.99 volts. Reconnected to car, still showing 12.8 in accessory position, started engine, and reading > 14 volts from alternator as you would expect. Everything magically back to normal. Glad I took a video of the performance previously. Still want to know what happened.
 

·
Registered
Joined
·
47 Posts
Discussion Starter #5
Well, battery was still fully charged after sitting overnight. 12.8 volts. Van started fine .. drove it to dealership (5 miles) and battery indicator came on again after about 3-4 miles. It's with the dealer now; they are testing it.
 

·
Registered
Joined
·
47 Posts
Discussion Starter #6
Generator failure

Back from dealership.

Generator replaced under warranty: the old one was only outputting 9 volts instead of over 13.
Repair would have been $500 or so outside of warranty. New one is only covered for 12k/1 year (presumably just parts not labor), but the remainder of the 3/36 warranty is longer at this point anyway. Apparently 3/36 also covers the battery. So, I guess I better hope it was just a rare bad generator...

They also did the M38 Recall for reprogramming the PCM, and -yes- finally the Econ mode jerk 1-3 shift is gone.. still an occasional clunk sound just before coming to a stand still in Econ mode though.
 

·
Registered
Joined
·
11 Posts
I had my alternator replaced this week under the 3/36. The dealer called it an internal fault. I have 29k on my 2012.
 

·
Registered
Joined
·
562 Posts
Sounds like they have a bad batch of alternators. Can you read where they are made?
 
1 - 10 of 10 Posts
Top