The Chrysler Minivan Fan Club Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
This is the one you push on the steering wheel that rotates through various mileages, speed, mpg, etc.

The mileage is displayed when the van is off, but when running I can only get the temperature. It doesnt change no matter how hard you push.
Cant imagine what a dealer will charge to replace that. I think thats all on one fuse with the dashboard displays. Any suggestions welcome
 

·
--UNKNOWN MEMBER--
Joined
·
12,066 Posts
Welcome.

You probably have a clock spring problem.
 

·
Super Moderator
Joined
·
24,383 Posts
Make sure you are pressing the bottom of the back button.

Maybe a battery disconnect and reconnection will clear that up. That display can be turned off I believe. Perhaps that has happened.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Make sure you are pressing the bottom of the back button.

Maybe a battery disconnect and reconnection will clear that up. That display can be turned off I believe. Perhaps that has happened.
Good suggestion - will keep it. It went to back to working better than ever a few days after I posted this. Must be karma I have in the bank.....
 

·
Super Moderator
Joined
·
6,305 Posts
The switch could be bad too.

Try "knocking" on the switch bank with your knuckles a couple times and see if that helps.

If replacing the buttons doesn't fix it, then I would agree that it's a clockspring issue.
 

·
Super Moderator
Joined
·
24,383 Posts
Good suggestion - will keep it. It went to back to working better than ever a few days after I posted this. Must be karma I have in the bank.....
A bit of karma is handy. :) Welcome to the Forum.
 
1 - 6 of 6 Posts
Top