The Chrysler Minivan Fan Club Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter · #1 ·
Hi all,

I have a new-to-me 2019 GC GT with the 430N RHB radio.

The navigation portion is very slow to respond when searching for things - it literally takes many minutes to find an address. Once found the rest of the navigation seems to work well.

Has anyone experienced similar issues?
 

·
Registered
Joined
·
2,366 Posts
That's not normal. Ours is fairly snappy. Still under warranty, right?
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #3 ·
Yes, it's still under warranty. I'll have to set up an appointment with the dealer service to get it checked out.
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #4 ·
Interestingly I find that the radio software version is 05.01.01 and that I have a system "0302". I can't find information anywhere about that particular version of the software so I don't think it's wise to try to update to 33.01.23 and then 50.01.01.
 

·
Registered
Joined
·
119 Posts
check the version of the actual navigation software, the garmin software and see what version it is on. I think the latest is 7.11 or 7.09 or such. My van is a 2014 town and country but it's always be rather snappy. Radio software is 50.01.01 like yours.
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #6 ·
check the version of the actual navigation software, the garmin software and see what version it is on. I think the latest is 7.11 or 7.09 or such. My van is a 2014 town and country but it's always be rather snappy. Radio software is 50.01.01 like yours.
The Garmin software is indeed 7.09.

But the radio itself is 05.01.01 - that is not a typo. It is not 50.01.01. I have seen no reference anywhere to such a low version of the radio software.
56511
 

·
Registered
Joined
·
119 Posts
Thats really weird, I'm sure it's 50.01.01 but not sure why it's backwards like that. Unfortunately it looks like you're at the latest and the dealership's aren't much help when it comes to these things from my experience. You might try puling the fuse for the radio or unhooking the battery to try to get it to reboot and see if that helps it.
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #8 ·
Thanks for the suggestion to pull the fuse, I hadn't tried that.

Unfortunately after 10 minutes without the fuse there is no change in the behavior. I had called Garmin tech support and Dodge tech support earlier in the day and neither could solve the problem. So I have scheduled a dealer service visit and will wait to see the result from that.

I really doubt the radio is at 50.01.01 - I work in tech and I think it would be highly unlikely to see such behavior. I will take a look at some of the other used GTs at the dealership when I drop the vehicle off on Thursday afternoon.
 

·
Registered
Joined
·
2,366 Posts
I just checked the '19 we have as a loaner right now. Same stuff/numbers you have. Except it is nice and quick when searching.
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #10 ·
I just checked the '19 we have as a loaner right now. Same stuff/numbers you have. Except it is nice and quick when searching.
Thank you for checking on that for me. I'll post after the dealer visit - I hope they can do something for me, it's my first experience with this particular dealership (and my first Dodge/Chrysler product).
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #12 ·
Well, the replacement head unit was indeed the fix for the slow nav and now it shows the Gracenote version too.

For certain the radio version is 05.01.01. New unit has the same 2019 maps loaded.
 

·
Registered
Joined
·
2,366 Posts
Curious... Does the new one automatically switch back to radio from any other source when you power cycle the van?
 

·
Registered
Joined
·
31 Posts
Discussion Starter · #14 ·
Curious... Does the new one automatically switch back to radio from any other source when you power cycle the van?
Yes, that behavior did not change - with an old school Ipod plugged in, it goes back to the FM radio each time. I have not tested with CDs or USB devices.
 

·
Registered
Joined
·
228 Posts
My 430n I believe is the number only has backup camera and CD
When I turn off vehicle then restart next day it always goes back to what I was listening to before. It aggravating cause I have to hit radio or plug phone in Port.
 
1 - 15 of 15 Posts
Top