The Chrysler Minivan Fan Club Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
282 Posts
The '96 is very iffy. I think your question may be a non-starter if you have the 3-speed auto...don't think any of those came with a tach - or would accommodate a tach cluster. This eBay vendor has a pretty good explanation in the text below his ad:


All in all this is a pretty common upgrade, so somebody here may be of better assistance. I did the upgrade on my 2005 SE, which was 100% plug & play. Just not sure about the 1996...
 
  • Like
Reactions: rkirbyn

·
3rd gen > all others
Joined
·
4,572 Posts
I don't know, not enough information. Is this a Caravan or Grand Caravan? The Grand Caravan would be better optioned and more likely to have it, as they have the long wheelbase, came with the 3.0 engine.

Does it have the 3 speed transmission or the electronic 4 speed 41TE? If the 41TE, you could try removing and cleaning the input and output speed sensors on the front of the transmission as they are magnetic pick-up and can get metallic grit on them that fouls the signal. Sometimes the wires/connectors break and cause problems too (especially the lower sensor).

There is also a problem with the solder joint on the cluster, the plug-to-printed circuitboard soldered connection sometimes cracks. People have heated up and reflowed the solder to fix it, but that requires removing the cluster. Is there a fuse for the instrument cluster to check? Would be faster than removing the cluster if that's the problem. The manual gearshift needle/indicator makes R&R of the cluster more time consuming.
 
  • Like
Reactions: rkirbyn

·
Registered
Joined
·
11 Posts
Discussion Starter · #5 ·
caravan with three speed.i already heated up the solder joints at the connecter.also the horn and parking lights don't work.checked all the fuses.bought the remanufactured bcm off ebay.
 

·
3rd gen > all others
Joined
·
4,572 Posts
Even the fuses under the dash, driver's side? I guess you'd know about that hidden fuse box if you replaced the BCM, as that is next to it.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #7 ·
i installed a used cluster from a 1999.everything but the dash lights seem to work now.dash light problem is probably tied to the park lights not working problem.still its nice to know how much gas i have and how fast im going.
 
1 - 7 of 7 Posts
Top