The Chrysler Minivan Fan Club Forums banner
1 - 6 of 6 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Ok I have been dealing with this for over a week, Tried a whole lot. Today I seen a few Times Dash lit up and Said Error code E then it started a count and Gauges would jump according to numbers. Counting 1-10. Then goes Dark. Headlights come on Automatically runs good, but only top brake light works on back door. Radio works, blower motor works, no heat or air. Vanity works on visor. Power windows work. Put 3 different IPM control modules in. Tried new fuses. New bulbs. I can take my instrument panel out and it drives the same. Help! I have a video of the counting.
Motor vehicle Font Communication Device Line Red

Product Blue Communication Device Font Motor vehicle

Communication Device Telephony Font Gadget Red
 

· Registered
Joined
·
2 Posts
Discussion Starter · #2 ·
I have a 2005 T&C Touring and for almost 2 weeks I have been trying to figure it out and learn along the way. Instrument panels and gauges flashed and went out. Runs fine. Tried replacing the module with the fuses and the fuses, tried a new instrument panel didn’t work. Blinkers and brake lights don’t work except one one the back door, blower works but no heat or air. Wipers don’t work, power windows do. Radio works vanity light works and headlights and taillights come on automatically. Instrument panel came on a few times to day and looked like it was counting 1-10 and gauges jumped around. Any ideas?
Light Communication Device Telephony Font Portable communications device

Font Line Motor vehicle Communication Device Material property

Light Font Line Red Communication Device

Speedometer Gauge Odometer Tachometer Measuring instrument
 

· Registered
Joined
·
1,594 Posts
check the connection quality of the smaller cable that runs off the big positive battery terminal

check underneath the IPM for corrosion
 

· Registered
Joined
·
479 Posts
I would guess the problem is related to the BCM and or associated wiring. If you consider replacing it, be aware it may be part of the security system of the vehicle making it impossible to start the van if done incorrectly. Check all connections and wires to and from the BCM. Remove and re-seat all connectors.

Disconnect both terminals at battery, hold the - and + leads together for a minute [battery is not involved in this at all] reconnect leads to battery. This may re-set the system.

Couple of related videos here...


 

· Registered
2006 Dodge Caravan SXE
Joined
·
1,349 Posts
I have a 2005 T&C Touring and for almost 2 weeks I have been trying to figure it out and learn along the way. Instrument panels and gauges flashed and went out. Runs fine. Tried replacing the module with the fuses and the fuses, tried a new instrument panel didn’t work. Blinkers and brake lights don’t work except one one the back door, blower works but no heat or air. Wipers don’t work, power windows do. Radio works vanity light works and headlights and taillights come on automatically. Instrument panel came on a few times to day and looked like it was counting 1-10 and gauges jumped around. Any ideas?
Did any of the suggestions help? Whats the van doing now?
 
1 - 6 of 6 Posts
Top