The Chrysler Minivan Fan Club Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I just came home only to find that my brake lights wouldn't cut off. I have 2 batteries (1 for my audio and 1 up front), i pulled my battery up front and the brake lights were still on, so i had to pull my audio battery because it was powering the car. Does anyone have any ideas why of just pulling my main battery didn't work or even what the problem even sounds like? I think my main battery is dead because this happened before and once i changed the battery my brake lights went out.
 

·
Premium Member
Joined
·
10,109 Posts
Well you had to disconnect both batteries because the audio one is still connected to the whole system. The brake lights themselves may be a bad switch by the pedal.
 

·
fix it if you can
Joined
·
5,076 Posts
Does anyone have any ideas why of just pulling my main battery didn't work or even what the problem even sounds like?
your aux battery was/is not diode isolated! (from the main power distribution system)
This can cause problems - depending on how the second battery is spliced into the system... (and size/capacity of the said battery)

Typically, when adding a secondary power system (battery + high amp circuit) the only connection to the main power is a charge controller (connected to a "RUN" active circuit) - this prevents the secondary circuit from draining the main battery and power distribution system..

as for brake light problem:
it's either bad brake light switch (on brake pedal)
OR a controller/circuit problem
 
1 - 3 of 3 Posts
Top