The Chrysler Minivan Fan Club Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi.

I'm currently fixing my 1995 Grand Voyager, 3,3L gasoline engine.

A few weeks ago, the head lights, brake lights, Power door Locks and Message center suddenly wasn't working. All at the same time. Have checked for blown fuses, both under dash and in the engine compartment, without finding anything wrong. :(

Also checked cables, connectors etc. for corrosion and breakage. Haven't found anything yet. :(

Anyone experienced the same problems, and might have a good suggestion for me ?

Greatful for all answers :)


Kind regards,
Ole Ostigaard
 

·
--UNKNOWN MEMBER--
Joined
·
13,318 Posts
Welcome to the forum.

I don't have experience on that particular model year but to me, everything points to a ground issue. Check all your grounding points for corrosion, especially the one under the battery tray, if yours have one there.
 

·
Registered
Joined
·
373 Posts
Not sure how you checked your fuses but if I may suggest -- the fuses under the dash area have two small round metal connectors embedded on TOP of the fuse.
If you put your positive side of the meter on one of these metal points on top of the fuse and put the negative side of the meter to ground with KEYON, you should be getting voltage.
If not backup to the relay -- assume you have a power distributon box under the hood like my 1994 SE -- as that is where power will originate to the fuse.
If still nothing, as LEVY points out, grounds may be the issue. FWIW, On the 1994 SE there is a hidden ground that wraps under the passenger side engine mount that is NOT obvious.
 
1 - 3 of 3 Posts
Top