The Chrysler Minivan Fan Club Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
We just recently started having a problem with our 2010 van. When you open the door every light on the cluster comes on and stays on and the wipers start running by themselves even while driving. I cleaned the battery terminals cause one was kinda corroded. It worked for about 5 minutes then it started up again. Would the cause be a bad iod fuse?
 

·
Registered
Joined
·
1,722 Posts
A failing battery has been seen to cause odd issues. I'd test it.
 

·
Super Moderator
Joined
·
27,888 Posts
A failing battery has been seen to cause odd issues. I'd test it.
I agree. Dirty current = relay issues. Expected battery like is about 5 years.

Does the battery start the vehicle per usual?

As for the fuse, it either works or it's blown, unless the contacts are dirty.
 

·
Registered
Joined
·
2,496 Posts
Didn't someone recently have a similar problem, and it was a broken wire somewhere? Dig back in posts from the last couple weeks. It'll be there.
 

·
Super Moderator
Joined
·
27,888 Posts
Didn't someone recently have a similar problem, and it was a broken wire somewhere? Dig back in posts from the last couple weeks. It'll be there.
Sliding door?
 

·
Registered
Joined
·
70 Posts
Didn't someone recently have a similar problem, and it was a broken wire somewhere? Dig back in posts from the last couple weeks. It'll be there.
There is a video of the same problem in youtube.

It was a shorted to ground CAN wire under the third row seats.
 

·
Administrator
2009 Dodge Grand Caravan SXT (3.8); 2003 Dodge Grand Caravan eL (3.8)
Joined
·
2,270 Posts
Didn't someone recently have a similar problem, and it was a broken wire somewhere?...
Yes, it was this thread: wipers run with switch off, post number 10.

The problem was a broken wire in the drivers door harness where the harness flexes when the door is opened and closed.
 

·
Registered
Joined
·
27 Posts
I had this problem once. Turned out the HVAC module was bad. When I unplugged it, the problem went away.
 

·
Registered
Joined
·
1 Posts
We just recently started having a problem with our 2010 van. When you open the door every light on the cluster comes on and stays on and the wipers start running by themselves even while driving. I cleaned the battery terminals cause one was kinda corroded. It worked for about 5 minutes then it started up again. Would the cause be a bad iod fuse?
I have the same problem with my 2008 Chrysler Town and Country I opened the driver's door and the windshield wipers come on and the dash lights all light up it has to be a short circuit from the wires in the door jamb for the windows that lead into the side of the dash it has to be a short for something it's only when I open the driver's door
 

·
Registered
Joined
·
6 Posts
It’s a broken wire (one of many) in the drivers door wiring harness. I’ve spliced at least five wires in that harness in our 08’. Each time, your exact symptoms.
 
1 - 11 of 11 Posts
Top