The Chrysler Minivan Fan Club Forums banner
1 - 20 of 23 Posts

·
Registered
Joined
·
862 Posts
Discussion Starter · #1 ·
06 grand caravan---sxt---124,000 miles, live in south florida..i am just a novice and have worked on my van doing things
I don't sense that i know alot about electrical...just seen things on you tube. don't see fuel pump wiring in haynes book
van cranks doesn't run at all, never had issues before
van has no codes
don't hear the hum from fuel pump when turn key on inside van or at where or gas inlet
i checked for spark between one of the coil connectors and plug wire,,saw spark jump
fuse fuel pump good
fuel pump relay swapped with a good one
85 and 87 on relay,,lights up with test light
86 on relay,,believe is ground,,,test light turns on
30 and 87 jumped with wire to initiated pump...but still not activated.
30/ground meter used for resistance got less then 5 ohms
ASD relay tested with meter the 2 pins on left, one at top one at bottom---they both showed 12v

Back probed (which i didn't even know the word prior to this issue) the harness on top gas tank. utube guy said tap back probe into blue and orange wire (he said its the 12v supply wire). So i stuck a safety pin as close as possible next to that
wire into the slot after pushing forward.
Held red connector from meter to needle and touched black lead to chassie of the van (hope that was a good ground and good red lead.
Wife turn key to "on" position. results about 2 volts
Question: What am i doing wrong?
Question: after 3 seconds with key to the on position will the Volts going to harness terminate for testing unless the car stays running (which it cannot).
Question: should i remove battery from van and take it back to rear of van after disconnecting the female part of the harness to the male and have a wire go from the positive pole of battery to the supply wire to see if it runs the pump, heck i don't even know if that is a method to test by.
 

·
3rd gen > all others
Joined
·
4,580 Posts
Yes, bad injector harness was only from 2001 to 2004 vans. Your 2006 is unaffected.
 

·
Registered
Joined
·
862 Posts
Discussion Starter · #6 ·
I want to test if the fuel pump is working or not by the simplest way. So....
With key to the ON position should i get a constant 12 volts at the fuel pumps harness under the van or will it stay on for 2 or 3 seconds only unless the engine is running (which mine doesn't)

Second---can i test to see if the fuel pump is working by running a wire from the 12volt battery positive post
directly to the fuel pump harness' 12volt wire,( hopefully it is the blue/orange wire)

If i can do the above do I need to run another wire from battery to the negative pole of battery to the harness' ground wire to test if fuel pump is good.
 

·
Registered
Joined
·
3,537 Posts
First, make sure accessories are turned off, then turn key to the 'on' position, the pump will run for a few seconds to prime the system. If you can't hear it, have someone either go under the tank and listen or go to the back of the van and listen.

If no pump, use starter fluid to see if it will start and run for a few seconds.
 

·
Registered
Joined
·
862 Posts
Discussion Starter · #12 ·
First, make sure accessories are turned off, then turn key to the 'on' position, the pump will run for a few seconds to prime the system. If you can't hear it, have someone either go under the tank and listen or go to the back of the van and listen.

If no pump, use starter fluid to see if it will start and run for a few seconds.
did try several times listening for the pump....no sound....will try fuel spray tomorrow....thanks
 

·
Registered
Joined
·
862 Posts
Also, you can do the key 'on' test as many times as you want. Even a thousand times, or a million times. The pump will run for a few seconds every time!
in past i did hear the sound when the van was running. few days ago crank,,,,no start.,,,no hum at all anymore after over and over turning key on and off. i test the continuity of coil windings for resistance with meter,,,red lead to #30 of fuel pump relay and black lead to negative pole of battery for grounding...

.i got an "OL" on meter...from what I understand and might be wrong,,,the windings in the fuel pump are wide open. I hope that is the story, because it would tell me I can go ahead and replace the pump, instead of testing over and over things in van
 

·
Registered
Joined
·
862 Posts
Discussion Starter · #14 ·
Check out my video on testing and changing the fuel pump. I checked some things you didn't mention.

(1) 01 DGC Fuel Pump Check and Replacement - YouTube
thanks you I ran that electrical test to the harness as he did. this this tonight. still no volts at the harness.
this stinks. I would pay someone 3 00bucks to fix the problem. but i don't want to pay and then not have them fix the problem
 

·
Registered
Joined
·
862 Posts
Discussion Starter · #18 ·
If you can't, I'll try and download one for you, but it is good to have your own account as the service also has TSB's and rudimentary repair info.
thanks marvin...a friend sent me a schematic over the phone. you're nice for willing...thanks marvin
I might be getting over my head in solving the problem...."how to find the wire that is maybe causing the ground issue"
 
1 - 20 of 23 Posts
Top