The Chrysler Minivan Fan Club Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
This one has me about to go nuts. 1993 Caravan 2.5 5 speed manual trans. 268K miles, up until now it just always works. Now it starts and runs fine, but no check engine light during startup and speedo, odometer, temp gauges don't work. Domelights don't work except manually on the lights, but the drivers door triggers a chatter from the BCM and the seatbelt light flashes dimly. Hooked up OTC scan tool on PCM, no codes, no issues. Discovered the OTC only works on the A604 trans version for CCD so I can't check the CCD bus. Fuses are good, swapped in second BCM but no change. Bus aren't rounded, and there is continuity from PCM to BCM on both. Factory service and body diagnostic manuals were no help.

Any suggestions?
 

·
Registered
Joined
·
1 Posts
Could be a second bad BCM? I have my 93 since new, and after about 150K it would start to occasionally stop working, dash lights, speedometer, Tachometer and done lights would go out. Headlights would still work.
It progressively got worst specially after rain for some odd reason at the time. It finally would spend more time not working then working.
I read that BCM's had high failure rate. I removed and inspected for cracked solder joints, re-soldered connectors, inspected wiring. No improvement.
The third time I was determined to find the problem. Used a magnifying glass and looked at every component. Found 2 surface mounted components with no solder at all on one side. Re-soldered over a year ago and has never failed again. Now at 236K.
I did however loose my intermittent wipers and wiper would not re-home after power off. After extensive checking, went back to BCM. Found I had bent 3 pins one connector. Straightened them and was good to go.
 
1 - 2 of 2 Posts
Top