The Chrysler Minivan Fan Club Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
The oil light is coming on when stopped. About 57K miles. The oil level is fine and the oil and filter have been changed every 5K. I changed the oil pressure sensor and still have the problem. No strange engine noises. Hard to believe it could be an oil pump or screen at this mileage. What should I do next?
 

·
Premium Member
Joined
·
10,109 Posts
Hook a mechanical gauge up to make sure the engine is healthy.
 

·
Registered
Joined
·
1,817 Posts
Hook a mechanical gauge up to make sure the engine is healthy.
The only thing I would add to that is do it now...because if the oil pressure is low, major engine damage could be close behind and it might be as simple as replacing the oil pump...unless it's just the sending unit or gauge.

I would follow Andy's advice like....yesterday. Without driving it until done.
 

·
Registered
Joined
·
1,927 Posts
The only thing I would add to that is do it now...because if the oil pressure is low, major engine damage could be close behind and it might be as simple as replacing the oil pump...unless it's just the sending unit or gauge.

I would follow Andy's advice like....yesterday. Without driving it until done.
I had this problem way back when I owned an 89 Dynasty 3l. engine. I tried everything even replacing the oil pump, some mechanic told me that doesn't even help on those engines as he has tried that as well. Even tried thicker oil and additives in vain. As soon as you wouls give it throtle the oil pressure would rise. You don't need much oil pressure at idle. That engine was still running at 300,000 KLM when I gave it to my son.
 
1 - 4 of 4 Posts
Top