The Chrysler Minivan Fan Club Forums banner
1 - 16 of 16 Posts

·
Registered
Joined
·
814 Posts
Discussion Starter · #1 ·
Looks like our 7 year old van is starting to have things show up. We had just been through an issue where the engine light was coming on after being in the shop for the same issue three times. Now that that was over, the light came on again, but for something different, P0128.

We checked that the radiator was full, it was. We didn’t see signs of a leak. The temp gaquge behaves normally, and the heater works fine. It doesn’t seem like the thermostat is bad.. We will take it in Thursday to get it checked. I am wondering what it could be.
 

·
Registered
2013 Dodge Grand Caravan
Joined
·
4,272 Posts
Thermostat is slightly stuck open. Code is for a momentary over-cooling issue. All it really mean is you burn a bit more gas on warm-up.
 
  • Like
Reactions: 2016T&C LP

·
Registered
Joined
·
722 Posts
Looks like our 7 year old van is starting to have things show up. We had just been through an issue where the engine light was coming on after being in the shop for the same issue three times. Now that that was over, the light came on again, but for something different, P0128.

We checked that the radiator was full, it was. We didn’t see signs of a leak. The temp gaquge behaves normally, and the heater works fine. It doesn’t seem like the thermostat is bad.. We will take it in Thursday to get it checked. I am wondering what it could be.
Likely due to the thermostat that should have been changed at 80k when the cooling system was serviced....... Which I'd bet never happened.

Now the failing thermostat is opening too quickly causing the vehicle to take too long to reach operating temp, in turn throwing a CEL.
 

·
Registered
Joined
·
814 Posts
Discussion Starter · #4 ·
I overlooked that the cooling system needed servicing at 80 k miles It was in for a new transmission then. I will have to look at the maintenance schedule to see if I missed that and anything else.
 

·
Registered
Joined
·
814 Posts
Discussion Starter · #5 ·
Likely due to the thermostat that should have been changed at 80k when the cooling system was serviced....... Which I'd bet never happened.

Now the failing thermostat is opening too quickly causing the vehicle to take too long to reach operating temp, in turn throwing a CEL.
I went and checked the maintenance schedule and it says the cooling system service should be done at 100,000 miles. I guess it will be done early at 89,000 now.
 

·
Registered
Joined
·
722 Posts
I went and checked the maintenance schedule and it says the cooling system service should be done at 100,000 miles. I guess it will be done early at 89,000 now.
Anyone who knows these vans knows cooling system/thermostat is done between 60-80k miles.
Just like the they know the transmission should have fluid/filter changes done every 50k miles minimum and that ECON mode should never be used.
They know that oil should be changed every 4-5k miles using only MS-6395 certified synthetic, unless you like expensive top end repairs.

The book for these vans is optimistic at best. Simple regular maintenance getting stretched out further than it should is the cause of a large percentage of their issues.
 

·
Registered
Joined
·
2,703 Posts
Most of those points are debatable.
 

·
Registered
Joined
·
814 Posts
Discussion Starter · #8 ·
Anyone who knows these vans knows cooling system/thermostat is done between 60-80k miles.
Just like the they know the transmission should have fluid/filter changes done every 50k miles minimum and that ECON mode should never be used.
They know that oil should be changed every 4-5k miles using only MS-6395 certified synthetic, unless you like expensive top end repairs.

The book for these vans is optimistic at best. Simple regular maintenance getting stretched out further than it should is the cause of a large percentage of their issues.
I’ve been here for a long while, but this is the first time I had heard you should do a cooling system flush 20k miles before schedule. Everyone who comes here does not know everything.
 

·
Registered
Joined
·
722 Posts
I’ve been here for a long while, but this is the first time I had heard you should do a cooling system flush 20k miles before schedule. Everyone who comes here does not know everything.
Quite realistically, most who come here know nothing, that's why they're here. Unfortunately, they don't generally show up until there's an issue. This is no offense to you or anyone else, but the majority of issues could easily be negated simply by researching and learning about the van.

Thermostats have always been an issue with Pentastar engines. The Charger, Challenger, 300, Jeeps, etc all share the same issue. Simply doing the regular service ahead of "book schedule" keeps it from being an issue.
Sure there are some who make it 200k miles without ever doing it, for every 1 of those people, there's 10 whom have them fail under 100k.
 

·
Registered
Joined
·
814 Posts
Discussion Starter · #10 ·
I’ve read that about spark plugs here, but this is the first time for this issue. I do understand what you’re saying though. I changed transmission fluid and filter every 30 miles and still need a new transmission at 81K. The van is at the dealer now and we’re waiting for their diagnosis now.
 

·
Registered
Joined
·
65 Posts
I get this code even after replacing my thermostat/radiator/coolant flush/water pump, I would just get a scanner and delete the code when it pops up. Code will stop popping up when weather gets warmer. It's harmless.
 

·
Registered
Joined
·
814 Posts
Discussion Starter · #12 ·
We have the van back. The thermostat will be replaced when the parts arrive. I guess it’s also time for a drain, flush, and refill of the coolant since they are working on this anyway.

The light is off now because they reset it. We’ll have the above work done regardless of whether it comes one again or not. We expect to go on a long trip this summer, so we’re to going to have this done so there won’t be a problem while on the trip..
 
  • Like
Reactions: Sienile

·
Registered
Joined
·
814 Posts
Discussion Starter · #13 ·
I took it the dealer last month after starting this thread. They diagnosed it as thermostat and gave it back to me while we wait for the parts they had to order. It was supposed to tkat 3-5 days for the parts to arrive. We’re still waiting several weeks later. Meanwhile, the light was on again for 4 or 5 days and then went out. Since then there has been no light or code. We will go ahead with the repair if the parts ever come in. Things must be bad if it takes this long to get parts.
 

·
Registered
Joined
·
65 Posts
Probably better to DIY this with a thermostat from AutoZone, it's super easy and I wouldn't be surprised if thermo replacement doesn't fix the issue. I get this code whenever I blast the heat and it's cold out.
 

·
Registered
Joined
·
814 Posts
Discussion Starter · #16 ·
I wish I could do it myself, but I am not physically able. Secondly, it’s being covered by Max-Care,, at least part of it is, if not all of it.
 
1 - 16 of 16 Posts
Top