The Chrysler Minivan Fan Club Forums banner
1 - 6 of 6 Posts

· Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I’ve got the p0302 code on my 2014 caravan. It has 155,000 miles on it. It has been in the shop a few times for rockers arms and camshaft. We have taken meticulous care with maintenance. Now we got the p0302 misfire on cyl 2. It’s been to two different shops and they have both changed out the spark plug and coil pack and did leak down test of the cylinder check camshafts and rockers. The second shop changed out the injector and still didn’t help. The mechanic did say when he had it torn apart it looked like the #2 injector may have been spraying more fuel. He had the valve cover off when he observed this so I’m not sure what he was seeing. His next plan will be to tear off the front of the engine and check timing and cam phaser on that side. $300 to do that and he doesn’t seem to convinced that’s what it is. So far I’ve got over $500 in diagnosis fees and the vehicle still runs like crap and has same code. Any help would be appreciated.
 

· Registered
Joined
·
2 Posts
I’ve got the p0302 code on my 2014 caravan. It has 155,000 miles on it. It has been in the shop a few times for rockers arms and camshaft. We have taken meticulous care with maintenance. Now we got the p0302 misfire on cyl 2. It’s been to two different shops and they have both changed out the spark plug and coil pack and did leak down test of the cylinder check camshafts and rockers. The second shop changed out the injector and still didn’t help. The mechanic did say when he had it torn apart it looked like the #2 injector may have been spraying more fuel. He had the valve cover off when he observed this so I’m not sure what he was seeing. His next plan will be to tear off the front of the engine and check timing and cam phaser on that side. $300 to do that and he doesn’t seem to convinced that’s what it is. So far I’ve got over $500 in diagnosis fees and the vehicle still runs like crap and has same code. Any help would be appreciated.
Have you been able to resolve the issue?

I have not taken mine in to the local dealer, and won’t. Had a terrible experience with them when I first bought this van, and am refusing to go back. I’ll drive an hour and go to a different dealer before I would go back to my local one.

I have a 2013 T&C, that started throwing the same code about 2 weeks ago. I just got new coil packs and plugs that I’m putting in it later today.

I’ve read that worst case scenario, the head needs to be replaced.

It’s also throwing P0456 (very small EVAP leak detected), and has been for several months. I’ve read that they can be related, but not so sure they are.
 

· Registered
Joined
·
1 Posts
Have you been able to resolve the issue? I have not taken mine in to the local dealer, and won’t. Had a terrible experience with them when I first bought this van, and am refusing to go back. I’ll drive an hour and go to a different dealer before I would go back to my local one. I have a 2013 T&C, that started throwing the same code about 2 weeks ago. I just got new coil packs and plugs that I’m putting in it later today. I’ve read that worst case scenario, the head needs to be replaced. It’s also throwing P0456 (very small EVAP leak detected), and has been for several months. I’ve read that they can be related, but not so sure they are.
I put two bottles of Lucas fuel treatment through it and when my wife went to fill up I came out the next day and the check engine light was off and it started idling normal. We kind of suspected it was the fuel because it started after she filled up on an out of town trip. Not sure that was it but it did resolve. Unfortunately after that happened it started the notorious ticking sound and I took it back to the dealer and the rocker arm on number two cylinder was loose. I’m not sure that happened on it’s own or they did it because they had it in there two weeks prior with it tore down and supposedly checked all that. The warranty company told them to replace all the rocker arms on that side and so far it’s been running great.
 

· Registered
Joined
·
2 Posts
I put two bottles of Lucas fuel treatment through it and when my wife went to fill up I came out the next day and the check engine light was off and it started idling normal. We kind of suspected it was the fuel because it started after she filled up on an out of town trip. Not sure that was it but it did resolve. Unfortunately after that happened it started the notorious ticking sound and I took it back to the dealer and the rocker arm on number two cylinder was loose. I’m not sure that happened on it’s own or they did it because they had it in there two weeks prior with it tore down and supposedly checked all that. The warranty company told them to replace all the rocker arms on that side and so far it’s been running great.
I did a sea foam upper cylinder treatment to it 2 1/2 weeks ago. Judging by how much it smoked, it’s never had it done to it before.
I did the tuneup on it last weekend. I uploaded a picture o what all 6 plugs looked like. That is the plug from cylinder 2, which was throwing the code.
Tire Automotive tire Automotive lighting Hood Finger

It’s running a lot smoother now, driven 100 miles since the tuneup, and hasn’t thrown a single code, knock on wood.
 
1 - 6 of 6 Posts
Top